use strict;
my $str = '/Class and Namespace Capture
Nam_e
\\_Nam_e
Nam_e\\Spac_e
/Class Method and Namespace Capture
/With Operation and Target
Nam_e::set_Singular
\\Nam_e\\Spac_e::isSingular
\\Nam_e\\Spac_e::
/Class Method and Deep Namespace Capture
/Without Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::setsingular
\\Nam_e\\Spac_e\\Accessible\\Caller\\Value::singular
/Class Method and Deep Namespace Capture
/With Mutator Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::setSingular
/Class Method and Deep Namespace Capture
/With Accessor Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::get_singular
/Class Method and Deep Namespace Capture
/With Conditional Operation and Target
\\Nam_e\\Spac_e\\Accessible\\Caller\\Value::isSingular
Nam_e\\Spac_e\\Accessible\\Caller\\Value::has_Singular';
my $regex = qr/(?<class>^(?<fully_qualified_class_name>(?<deliniator>(?<!\\)\\(?!\\)(?=(?P>fully_qualified_class_name))){0,1}[A-z_][\w]*)(?=::(?P>method)|$)|^(?<namespace>^(?P>fully_qualified_class_name)*)(?P>deliniator)(?P>fully_qualified_class_name)(?=::(?P>method)|$))(?<scope_resolution_operator>::(?=(?P>method)(?!$)))?(?<method>(?<=::)(?<operation>(?<mutator>[sS]et(?=[A-Z0-1_]|$))|(?<accessor>[gG]et(?=[A-Z0-1_]|$))|(?<condition>[iI]s(?=[A-Z0-1_]|$)|[hH]as(?=[A-Z0-1_]|$)))?_?(?<target>(?<=\w)\w*)|[A-z_]\w*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}