$re = '/(?<class>^(?<fully_qualified_class_name>(?<deliniator>(?<!\\\\)\\\\(?!\\\\)(?=(?P>fully_qualified_class_name))){0,1}[A-z_][\w]*)(?=::(?P>method)|$)|^(?<namespace>^(?P>fully_qualified_class_name)*)(?P>deliniator)(?P>fully_qualified_class_name)(?=::(?P>method)|$))(?<scope_resolution_operator>::(?=(?P>method)(?!$)))?(?<method>(?<=::)(?<operation>(?<mutator>[sS]et(?=[A-Z0-1_]|$))|(?<accessor>[gG]et(?=[A-Z0-1_]|$))|(?<condition>[iI]s(?=[A-Z0-1_]|$)|[hH]as(?=[A-Z0-1_]|$)))?_?(?<target>(?<=\w)\w*)|[A-z_]\w*)?$/m';
$str = '/Class and Namespace Capture
Nam_e
\\_Nam_e
Nam_e\\Spac_e
/Class Method and Namespace Capture
/With Operation and Target
Nam_e::set_Singular
\\Nam_e\\Spac_e::isSingular
\\Nam_e\\Spac_e::
/Class Method and Deep Namespace Capture
/Without Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::setsingular
\\Nam_e\\Spac_e\\Accessible\\Caller\\Value::singular
/Class Method and Deep Namespace Capture
/With Mutator Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::setSingular
/Class Method and Deep Namespace Capture
/With Accessor Operation and Target
Nam_e\\Spac_e\\Accessible\\Caller\\Value::get_singular
/Class Method and Deep Namespace Capture
/With Conditional Operation and Target
\\Nam_e\\Spac_e\\Accessible\\Caller\\Value::isSingular
Nam_e\\Spac_e\\Accessible\\Caller\\Value::has_Singular';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);