package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bREQ_\w+`)
var str = `1 | 2 | REQ_123 | 6 | 7
1 | 2 | abc REQ_123 | 6 | 7
1 | 2 | REQ_123 | 6 | 7
1 | 2 | ABCREQ_123 | 6 | 7
1 | 2 | REQ123 | 6 | 7
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}