// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bREQ_\w+").unwrap();
let string = "1 | 2 | REQ_123 | 6 | 7
1 | 2 | abc REQ_123 | 6 | 7
1 | 2 | REQ_123 | 6 | 7
1 | 2 | ABCREQ_123 | 6 | 7
1 | 2 | REQ123 | 6 | 7
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}