import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bREQ_\\w+";
final String string = "1 | 2 | REQ_123 | 6 | 7\n"
+ "1 | 2 | abc REQ_123 | 6 | 7\n"
+ "1 | 2 | REQ_123 | 6 | 7\n"
+ "1 | 2 | ABCREQ_123 | 6 | 7\n"
+ "1 | 2 | REQ123 | 6 | 7\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}