const regex = /\bREQ_\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bREQ_\\w+', 'g')
const str = `1 | 2 | REQ_123 | 6 | 7
1 | 2 | abc REQ_123 | 6 | 7
1 | 2 | REQ_123 | 6 | 7
1 | 2 | ABCREQ_123 | 6 | 7
1 | 2 | REQ123 | 6 | 7
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}