package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B([A-Z]+)`)
var str = `ABC`
var substitution = " $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}