use strict;
my $str = 'ABC';
my $regex = qr/\B([A-Z]+)/p;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";