#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?\/.*?\/\K.*$"
Local $sString = "url.com/folder1/xxx/index.html" & @CRLF & _
"url.com/folder2/" & @CRLF & _
"url.com/folder3/xxx/yyyy/index.html" & @CRLF & _
"url.com/folder4/zzz/aaa/bbb/index.html"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)