import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\/.*?\\/\\K.*$";
final String string = "url.com/folder1/xxx/index.html\n"
+ "url.com/folder2/\n"
+ "url.com/folder3/xxx/yyyy/index.html\n"
+ "url.com/folder4/zzz/aaa/bbb/index.html";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}