# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?\/.*?\/\K.*$"
test_str = ("url.com/folder1/xxx/index.html\n"
"url.com/folder2/\n"
"url.com/folder3/xxx/yyyy/index.html\n"
"url.com/folder4/zzz/aaa/bbb/index.html")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.