const regex = /^(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/(?:www\\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|www\\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|https?:\\\/\\\/(?:www\\.|(?!www))[a-zA-Z0-9]\\.[^\\s]{2,}|www\\.[a-zA-Z0-9]\\.[^\\s]{2,})$', 'mg')
const str = `http://video.google.co.uk:80/videoplay?docid=-72469230&hl=en#hello
https://ec2-52-74-229-167.ap.amazonaws.com/hive/admin/register
file:///C:/Users/thusharakrra/Desktop/index.html
localhost:8080
https://www.crimsonlogic.com
https://crimsonlogic.com
www.crimsonlogic.com
http://www.crimsonlogic.com
http://crimsonlogic.com
ftp://crimsonlogic.com
wwwcrimson.com
dsdsadasdasd
sdasdsahttps://dsadasd
sdasdsahttps://dsadasd.com
http://crimsonlogic.comdsadasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}