$re = '/^(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})$/m';
$str = 'http://video.google.co.uk:80/videoplay?docid=-72469230&hl=en#hello
https://ec2-52-74-229-167.ap.amazonaws.com/hive/admin/register
file:///C:/Users/thusharakrra/Desktop/index.html
localhost:8080
https://www.crimsonlogic.com
https://crimsonlogic.com
www.crimsonlogic.com
http://www.crimsonlogic.com
http://crimsonlogic.com
ftp://crimsonlogic.com
wwwcrimson.com
dsdsadasdasd
sdasdsahttps://dsadasd
sdasdsahttps://dsadasd.com
http://crimsonlogic.comdsadasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);