use strict;
my $str = 'http://video.google.co.uk:80/videoplay?docid=-72469230&hl=en#hello
https://ec2-52-74-229-167.ap.amazonaws.com/hive/admin/register
file:///C:/Users/thusharakrra/Desktop/index.html
localhost:8080
https://www.crimsonlogic.com
https://crimsonlogic.com
www.crimsonlogic.com
http://www.crimsonlogic.com
http://crimsonlogic.com
ftp://crimsonlogic.com
wwwcrimson.com
dsdsadasdasd
sdasdsahttps://dsadasd
sdasdsahttps://dsadasd.com
http://crimsonlogic.comdsadasd';
my $regex = qr/^(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}