using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:0[1-9]|1[012])([-.\/])(?:0[1-9]|[1-2][0-9]|3[01])\1(?:[0-9]{4})";
string substitution = @"$1\n$2string$3$4";
string input = @"mm-dd-yyyy
12-12-1212
12.12.1212
12/12/1212
But NOT match to dates using any other symbols like this:
12~12~1212
12=12=1212";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}