const regex = /(?:0[1-9]|1[012])([-.\/])(?:0[1-9]|[1-2][0-9]|3[01])\1(?:[0-9]{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:0[1-9]|1[012])([-.\\\/])(?:0[1-9]|[1-2][0-9]|3[01])\\1(?:[0-9]{4})', 'g')
const str = `mm-dd-yyyy
12-12-1212
12.12.1212
12/12/1212
But NOT match to dates using any other symbols like this:
12~12~1212
12=12=1212`;
const subst = `$1\n$2string$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);