re = /(?:0[1-9]|1[012])([-.\/])(?:0[1-9]|[1-2][0-9]|3[01])\1(?:[0-9]{4})/
str = 'mm-dd-yyyy
12-12-1212
12.12.1212
12/12/1212
But NOT match to dates using any other symbols like this:
12~12~1212
12=12=1212'
subst = '$1\\n$2string$3$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result