import re
regex = re.compile(r"(?:0[1-9]|1[012])([-.\/])(?:0[1-9]|[1-2][0-9]|3[01])\1(?:[0-9]{4})")
test_str = ("mm-dd-yyyy\n\n"
"12-12-1212\n"
"12.12.1212\n"
"12/12/1212\n"
"But NOT match to dates using any other symbols like this:\n\n"
"12~12~1212\n"
"12=12=1212")
subst = "$1\\n$2string$3$4"
result = regex.sub(subst, test_str)
if result:
print(result)