#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.* TWY .*)"
Local $sString = "2109m when take-off from intersection with TWY D." & @CRLF & _
"123123 ther. " & @CRLF & _
"1503m when take-off from intersection with TWY C." & @CRLF & _
"2109m when take-off from intersection with TWY D." & @CRLF & _
"2109m when take-off from intersection with TWY D." & @CRLF & _
"2109m when take-off from intersection with TWY D." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")