// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.* TWY .*)").unwrap();
let string = "2109m when take-off from intersection with TWY D.
123123 ther.
1503m when take-off from intersection with TWY C.
2109m when take-off from intersection with TWY D.
2109m when take-off from intersection with TWY D.
2109m when take-off from intersection with TWY D.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}