import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.* TWY .*)";
final String string = "2109m when take-off from intersection with TWY D.\n"
+ "123123 ther. \n"
+ "1503m when take-off from intersection with TWY C.\n"
+ "2109m when take-off from intersection with TWY D.\n"
+ "2109m when take-off from intersection with TWY D.\n"
+ "2109m when take-off from intersection with TWY D.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}