re = /(.* TWY .*)/
str = '2109m when take-off from intersection with TWY D.
123123 ther.
1503m when take-off from intersection with TWY C.
2109m when take-off from intersection with TWY D.
2109m when take-off from intersection with TWY D.
2109m when take-off from intersection with TWY D.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end