using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(?:www\.)?([A-Za-z_0-9-]+)";
string input = @"urls = [""http://arxiv.org/pdf/1611.08097"", ""https://doi.org/10.1109/tkde.2016.2598561"", ""https://www.scopus.com/inward/record.uri?partnerID=HzOxMe3b&scp=85116544648&origin=inward""]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}