re = /https?:\/\/(?:www\.)?([A-Za-z_0-9-]+)/m
str = 'urls = ["http://arxiv.org/pdf/1611.08097", "https://doi.org/10.1109/tkde.2016.2598561", "https://www.scopus.com/inward/record.uri?partnerID=HzOxMe3b&scp=85116544648&origin=inward"]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end