// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://(?:www\.)?([A-Za-z_0-9-]+)").unwrap();
let string = "urls = [\"http://arxiv.org/pdf/1611.08097\", \"https://doi.org/10.1109/tkde.2016.2598561\", \"https://www.scopus.com/inward/record.uri?partnerID=HzOxMe3b&scp=85116544648&origin=inward\"]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}