#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3}) (.+?]) (\w+?) (\w+?) - (.+)$"
Local $sString = "2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Ends" & @CRLF & _
"2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Starts" & @CRLF & _
"2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa" & @CRLF & _
"2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 0] INFO NotificationSinkSB - [handleEvent] INFO-00000: *** Event received <FIRED> for Task <ID#3656:EOD0000014|Housekeeping - SQL > ***" & @CRLF & _
"2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getDataSource().dataSource for jdbc/sepdb_olap_non_xa is :com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource@f14b906" & @CRLF & _
"2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - tableName for Archiving:TX_CTC_PAV_RESULT_DETAIL" & @CRLF & _
"2022-08-30 06:00:38,183 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")