$re = '/(^\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3}) (.+?]) (\w+?) (\w+?) - (.+)$/m';
$str = '2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Ends
2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Starts
2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa
2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 0] INFO NotificationSinkSB - [handleEvent] INFO-00000: *** Event received <FIRED> for Task <ID#3656:EOD0000014|Housekeeping - SQL > ***
2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getDataSource().dataSource for jdbc/sepdb_olap_non_xa is :com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource@f14b906
2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - tableName for Archiving:TX_CTC_PAV_RESULT_DETAIL
2022-08-30 06:00:38,183 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);