import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(^\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2},\\d{3}) (.+?]) (\\w+?) (\\w+?) - (.+)$";
        final String string = "2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Ends\n"
	 + "2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Starts\n"
	 + "2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa\n"
	 + "2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 0] INFO NotificationSinkSB - [handleEvent] INFO-00000: *** Event received <FIRED> for Task <ID#3656:EOD0000014|Housekeeping - SQL > ***\n"
	 + "2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getDataSource().dataSource for jdbc/sepdb_olap_non_xa is :com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource@f14b906\n"
	 + "2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - tableName for Archiving:TX_CTC_PAV_RESULT_DETAIL\n"
	 + "2022-08-30 06:00:38,183 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}