import re
regex = re.compile(r"(^\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3}) (.+?]) (\w+?) (\w+?) - (.+)$", flags=re.MULTILINE)
test_str = ("2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Ends\n"
"2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - [purge] INFO-00000: Purging By SQL Starts\n"
"2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa\n"
"2022-08-30 06:00:38,181 [DefaultWorkManager.Alarm Pool : 0] INFO NotificationSinkSB - [handleEvent] INFO-00000: *** Event received <FIRED> for Task <ID#3656:EOD0000014|Housekeeping - SQL > ***\n"
"2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getDataSource().dataSource for jdbc/sepdb_olap_non_xa is :com.ibm.ws.rsadapter.jdbc.WSJdbcDataSource@f14b906\n"
"2022-08-30 06:00:38,182 [DefaultWorkManager.Alarm Pool : 1] INFO DynamicPurgerOlap - tableName for Archiving:TX_CTC_PAV_RESULT_DETAIL\n"
"2022-08-30 06:00:38,183 [DefaultWorkManager.Alarm Pool : 1] INFO ArrangeConnections - ArrangeConnections.getConnection().Getting connection for: jdbc/sepdb_olap_non_xa\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")