#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ ]{0,2}(?:[*]{3}(?P<Section>.*?)|[ ]+[*]{3}(?P<SubSection>.*?))(?:[ ]?[*]{3})?$"
Local $sString = " *** Section with no sub section" & @CRLF & _
" *** Section with sub section ***" & @CRLF & _
" *** Sub Section ***" & @CRLF & _
" *** Another section"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")