const regex = new RegExp('^[ ]{0,2}(?:[*]{3}(?P<Section>.*?)|[ ]+[*]{3}(?P<SubSection>.*?))(?:[ ]?[*]{3})?$', 'gm')
const str = ` *** Section with no sub section
*** Section with sub section ***
*** Sub Section ***
*** Another section`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}