re = /^[ ]{0,2}(?:[*]{3}(?P<Section>.*?)|[ ]+[*]{3}(?P<SubSection>.*?))(?:[ ]?[*]{3})?$/m
str = ' *** Section with no sub section
*** Section with sub section ***
*** Sub Section ***
*** Another section'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end