import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ ]{0,2}(?:[*]{3}(?P<Section>.*?)|[ ]+[*]{3}(?P<SubSection>.*?))(?:[ ]?[*]{3})?$";
final String string = " *** Section with no sub section\n"
+ " *** Section with sub section ***\n"
+ " *** Sub Section ***\n"
+ " *** Another section";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}