const regex = /(\d{4})(-)?(\d{2})(-)?(\d{2})(T)?(\d{2})(\:)?(\d{2})(\:)?(\d{2})(\+(\d{2}:\d{2})|\.(\d{3}Z)|Z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})(-)?(\\d{2})(-)?(\\d{2})(T)?(\\d{2})(\\:)?(\\d{2})(\\:)?(\\d{2})(\\+(\\d{2}:\\d{2})|\\.(\\d{3}Z)|Z)', 'gm')
const str = `2016-04-19T19:54:52.273Z
2016-04-20T11:54:59+00:00
2016-04-20T11:54:59Z
20160420T115459Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}