// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4})(-)?(\d{2})(-)?(\d{2})(T)?(\d{2})(\:)?(\d{2})(\:)?(\d{2})(\+(\d{2}:\d{2})|\.(\d{3}Z)|Z)").unwrap();
let string = "2016-04-19T19:54:52.273Z
2016-04-20T11:54:59+00:00
2016-04-20T11:54:59Z
20160420T115459Z";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}