# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{4})(-)?(\d{2})(-)?(\d{2})(T)?(\d{2})(\:)?(\d{2})(\:)?(\d{2})(\+(\d{2}:\d{2})|\.(\d{3}Z)|Z)"
test_str = ("2016-04-19T19:54:52.273Z\n"
"2016-04-20T11:54:59+00:00\n"
"2016-04-20T11:54:59Z\n"
"20160420T115459Z")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.