#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:.*-){2}|(?:.*\.){2})[a-zA-Z\d][a-zA-Z\d.-]{14}[a-zA-Z\d]$"
Local $sString = "dfdsfdsfdsfd..dd" & @CRLF & _
"dfdsfdsfdsf...dd" & @CRLF & _
"dfdsfd--dsfd..dd" & @CRLF & _
"dfdsfdsfdsf.d.dd" & @CRLF & _
"dfdsfdsfdsf-.-dd" & @CRLF & _
"df.sfdffdsfd..dd" & @CRLF & _
"ffdsfdsfd--sf.dd" & @CRLF & _
"ffdsfdsfdffsffd." & @CRLF & _
".fdsfdsfdr-sfrdd" & @CRLF & _
"ffdsfds.td-sftdd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")