import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:.*-){2}|(?:.*\\.){2})[a-zA-Z\\d][a-zA-Z\\d.-]{14}[a-zA-Z\\d]$";
final String string = "dfdsfdsfdsfd..dd\n"
+ "dfdsfdsfdsf...dd\n"
+ "dfdsfd--dsfd..dd\n"
+ "dfdsfdsfdsf.d.dd\n"
+ "dfdsfdsfdsf-.-dd\n"
+ "df.sfdffdsfd..dd\n"
+ "ffdsfdsfd--sf.dd\n"
+ "ffdsfdsfdffsffd.\n"
+ ".fdsfdsfdr-sfrdd\n"
+ "ffdsfds.td-sftdd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}