const regex = /^(?!(?:.*-){2}|(?:.*\.){2})[a-zA-Z\d][a-zA-Z\d.-]{14}[a-zA-Z\d]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:.*-){2}|(?:.*\\.){2})[a-zA-Z\\d][a-zA-Z\\d.-]{14}[a-zA-Z\\d]$', 'gm')
const str = `dfdsfdsfdsfd..dd
dfdsfdsfdsf...dd
dfdsfd--dsfd..dd
dfdsfdsfdsf.d.dd
dfdsfdsfdsf-.-dd
df.sfdffdsfd..dd
ffdsfdsfd--sf.dd
ffdsfdsfdffsffd.
.fdsfdsfdr-sfrdd
ffdsfds.td-sftdd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}