#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(ap)(.?)t"
Local $sString = "rap them" & @CRLF & _
"tapeth" & @CRLF & _
"apth" & @CRLF & _
"wrap/try" & @CRLF & _
"sap tray" & @CRLF & _
"87ap9th" & @CRLF & _
"apothecary" & @CRLF & _
"" & @CRLF & _
"aleht" & @CRLF & _
"happy them" & @CRLF & _
"tarpth" & @CRLF & _
"Apt" & @CRLF & _
"peth" & @CRLF & _
"tarreth" & @CRLF & _
"ddapdg" & @CRLF & _
"apples" & @CRLF & _
"shape the"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")