$re = '/(ap)(.?)t/';
$str = 'rap them
tapeth
apth
wrap/try
sap tray
87ap9th
apothecary
aleht
happy them
tarpth
Apt
peth
tarreth
ddapdg
apples
shape the';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);