using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ap)(.?)t";
string input = @"rap them
tapeth
apth
wrap/try
sap tray
87ap9th
apothecary
aleht
happy them
tarpth
Apt
peth
tarreth
ddapdg
apples
shape the";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}