import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ap)(.?)t";
final String string = "rap them\n"
+ "tapeth\n"
+ "apth\n"
+ "wrap/try\n"
+ "sap tray\n"
+ "87ap9th\n"
+ "apothecary\n\n"
+ "aleht\n"
+ "happy them\n"
+ "tarpth\n"
+ "Apt\n"
+ "peth\n"
+ "tarreth\n"
+ "ddapdg\n"
+ "apples\n"
+ "shape the";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}