package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\${[a-z]+\.[a-z]+\.[a-z]+\.|}`)
var str = `"Patient:
${ss.patient.howard.firstName} ${ss.patient.howard.lastName}
Gender: ${ss.patient.howard.sex}
Birthdate: ${ss.patient.howard.dob}
${ss.patient.howard.addressLine1}
Phone: (801)546-4765"
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}