const regex = /\${[a-z]+\.[a-z]+\.[a-z]+\.|}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\${[a-z]+\\.[a-z]+\\.[a-z]+\\.|}', 'g')
const str = `"Patient:
\${ss.patient.howard.firstName} \${ss.patient.howard.lastName}
Gender: \${ss.patient.howard.sex}
Birthdate: \${ss.patient.howard.dob}
\${ss.patient.howard.addressLine1}
Phone: (801)546-4765"
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);