import re
regex = re.compile(r"\${[a-z]+\.[a-z]+\.[a-z]+\.|}")
test_str = ("\"Patient:\n"
"${ss.patient.howard.firstName} ${ss.patient.howard.lastName}\n"
"Gender: ${ss.patient.howard.sex}\n"
"Birthdate: ${ss.patient.howard.dob}\n"
"${ss.patient.howard.addressLine1}\n"
"Phone: (801)546-4765\"\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)