using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^@]+)@(\S+)\s([^|]+)\|(.*)$";
string input = @"asd@lol kek|1.1.1.1
title@content m e s s a g e|2.3.4.5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}