package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^@]+)@(\S+)\s([^|]+)\|(.*)$`)
var str = `asd@lol kek|1.1.1.1
title@content m e s s a g e|2.3.4.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}