// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^@]+)@(\S+)\s([^|]+)\|(.*)$").unwrap();
let string = "asd@lol kek|1.1.1.1
title@content m e s s a g e|2.3.4.5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}