re = /^([^@]+)@(\S+)\s([^|]+)\|(.*)$/m
str = 'asd@lol kek|1.1.1.1
title@content m e s s a g e|2.3.4.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end